Bitrix24 Community

Support » Forum » Bitrix24 general questions » Cannot add external Google calendar
Pages: 1
RSS
Cannot add external Google calendar, caldav server response is 204 no content
Hi, I am new to bitrix24 and have the following problem with my calendar.        
After the following the directions to sync with Google Calendar, I am presented with a 204: No content error from the CalDAV server.

I follow the directions and enter all the details but always get the same error.
I have attached the pictures with the settings and the error message.
What am I doing wrong?

Thank you.
Hi Dimitris,

Please contact our Helpdesk with this screenshot. Thank you!

Yana.
I have contacted helpdesk, but got no reply yet.
After too many login failed attempts from your server,
I eventually had to change my password in google account.
After that Google calendar was added to my calendars.
However, only the events from Google are synced to Bitrix and not the other way around..
In your video you state two way sync, what is wrong?
Thanks
If you want events from Bitrix24 to be synchronized to your Google Calendar, you need to add events in your Bitrix24  to "google"calendar (you have an option to which calendar you want to add a new event).

Yana.
I am having the same problem and Changing my password did not help
Hi Daniel!

Please contact our Helpdeskwith the error screenshot (please provide more details to the HelpDesk staff so that they could assist, thank you!)
Kind Regards,

Yana.
I'm having the same problem, error 204, no content while checking the connection "Selvam Kanniah".

In my google calender site the calender name is exactly "Selvam Kanniah" , and the rest of the settings are correct.
I went Google security and did set the login attempts from USA server is authentic.  
Hi Selvam!

Please check carefully the parameters in address (check link), user name & password. Usually Google Calendar password change helps (though not always). If nothing of this helps - please contact the Helpdesk
Yana.
Same problem. And it's a little frustrating that there's no tutorial or work around for this and that we're all told to contact the Helpdesk.
Quote
And it's a little frustrating that there's no tutorial or work around for this and that we're all told to contact the Helpdesk.
Dear Jen!

We apologize for the inconvenience, but unfortunately we cannot state for sure what this problem is about, it happens from time to time with several of our users, the reason I ask you to contact the Helpdesk is that like this we can gather the statistics & have a closer look at the concrete case in order to find the solution. Thank you for the understanding.

Kind Regards,

Yana.
I've been having the same problem for 2 weeks without any new updates from help desk.  I know what the issue is.  Google changed the way security is done on both Google and Google apps products.
Found the fix! :D
I noticed I had several emails from Google indicating they blocked a "login attempt" all with time stamps close to my Bitrix24 calendar set up attempts. There was a link to adjust the security settings. If you click that it will take you to a page in your Google account settings that you can change the security level access of less secure apps. Mine was set to "disable". I switched it to "enable". Went through the set up again in Bitrix24. It did idle for awhile but no error 204 message. I finally just refreshed the page. BOOM! Google calendar now displayed in Bitrix24.

If you don't get the email with the link, here's the path to change it:
Google
Login
Account
Security
Less Secure Apps
Enable

Hope this helps!!
Thanks a lot Jen! Hope this can help other as well.

Please also note that this option is not yet available for Google corporate accounts.

Kind Regards,

Yana.  
This option is not available for Google apps customers.  the error message that I get is "less secure apps is not available for google apps. so people who have google apps are still stuck at 0.  When can I expect a fix for this?
Hi Daniel,

If the steps advised above didn't help, please contact the HelpDesk - please provide them more details if possible (so that they can differentiate problems & advise the solution faster) Thank you.

Yana.  
Hi I solved the issue and it is all on the Google side and their new security.

1. Sign into your Gmail/Google account.
2. As mention before go to your account settings and turn on access for less secure apps. Link> https://www.google.com/settings/security/lesssecureapps
3. Go to https://g.co/allowaccess and click continue.
4. Go to you Bitrix24 account and enter you calendar info again. It should finally take it.

If Google is still blocking access go to
https://security.google.com/settings/security/activity
look for the "Unknown Device" and tell Google it is your device. Mine says it is from "Washington DC (Hagerstown MD), Ashburn, VA, USA" IP Adress 54.204.206.75
Thanks David!

Yana.
David Thank you for your info however this is not working for google apps.  When I click on your 1st link I get this error message

Some apps and devices use less secure sign-in technology, which makes your account more vulnerable. You can turn off access for these apps, which we recommend, or turn on access if you want to use them despite the risks. Learn more
This setting is not available for Google Apps accounts.

When I go to your 2nd Link I get this

Allow access to your Google account

As a security precaution, Google may require you to complete this additional step when signing into a new device or application.

To allow access, click the Continue button below.

I then Click Continue and I get this message .

Account access enabled

So then I go back to Bitrix and try it again and still get the same Birtrix error message.  So then I try your last link

and nothing all the devices I have listed there are ones I use each day.  Iphone, Mac, PC.

I think there is still an issue for people who use google apps.

Hi Daniel!

We do not support Google apps Calendar & Bitrix24 integration yet, sorry.

Best,

Yana.
Do we have any news about it? Your main audience for bitrix24 is companies and companies are using corporate google mail accounts and google calendars is most popular. Please create any kind of special measure to avoid block from Google side if they still have this rule.
Hi Dmitry!

We would like to help but this is Google policy towards security, I'm afraid there isn't much we can do about that.

Best,

Yana.
same problem! so frustrating!
Hi B24_2559413!

We may be revising the calendar module for our fall release, thanks for the suggestion.

Best,

Yana.
Hello, seeing how many times this issue is brought up I also would like to vote for the google calendar fix.

For many months now there has been a change of policy in google authorisation. The same problem came up in Thunderbird and was fixed by a plugin called google provider allowing to authenticate the connection. Google withdrawed completely from davcal and now only calendar export via html, ical and xml is possible.
It would be great if you could fix this issue asap. Mamy users would benefit from it.

Nevertheless, great job with your product. I'm amazed with the widenes of funcionalities you developed and shared for free (compared to every free manager I've tested). I hope your policy in this matter stays :) Many small companies couldn't afford to pay for the monthly service, especialy in less wealthy countries.
Hi Krzysztof!

Thanks a lot for the kind words, and yes, we hope to do our best to fix the calendar issue. We will have our next big release this fall - stay tuned!  :)

Best,

Yana.
Quote
David Bowen wrote:
Hi I solved the issue and it is all on the Google side and their new security.

1. Sign into your Gmail/Google account.
2. As mention before go to your account settings and turn on access for less secure apps. Link>  https://www.google.com/settings/security/lesssecureapps
3. Go to  https://g.co/allowaccess  and click continue.
4. Go to you Bitrix24 account and enter you calendar info again. It should finally take it.

If Google is still blocking access go to
https://security.google.com/settings/security/activity
look for the "Unknown Device" and tell Google it is your device. Mine says it is from "Washington DC (Hagerstown MD), Ashburn, VA, USA" IP Adress  54.204.206.75
Thanks! It worked!
I have the same problem ([204] No Content) with regular @gmail account.

Changes at lesssecureapps didn't help :(

Also there is a notice at https://developers.google.com/google-apps/calendar/caldav/v2/guide:

The old endpoint https://www.google.com/calendar/dav is deprecated and no longer supported; use it at your own risk. We recommend you transition to the new endpoint format described above.

But that change also didn't help.
After several attempts it finally worked!

Now I'm trying to understand how to make it work: I accepted an invitation and I can see it @ Bitrix, but not in Google...
Yep, if I add an event then I see it@ Google, but if I accept an invitation - I don't
Hi!

Please contact our Helpdesk. Thanks!

Yana.
The problem as I see it is that the "Bitrix24 Connector" app doesn't request calendar access when setting up it's initial permissions...
The "allow access to less secure apps" fixed my issue but I would rather not leave that on for obvious reasons.
This should not be the case...Bitrix can access my entire drive of google documents but not my calendar???
Hi Michael,

Our devs will look into this issue later. Thanks for sharing.

Best,

Yana.
I have the same problem ([204] No Content) with regular @gmail account.

I have tried checking everything listed in the above issues. My settings are all correct, and I still get the 204 error. My boss was able to connect his, we have the same company google account, and very similar Apple laptops. I have tried all the fixes, I am officially frustrated.
Hi Ben,

Please allow access to less secure apps in your google settings - if it won't help, please contact our Heldpesk

Best,

Yana.
am having the same issue. I have my :allow unsecure apps" set to enabled, I changed my password. Still Nothing.  And the only reason I am trying to do this is so I can print a calendar...which cannot be done in this app?


error.png (263.67 Kb)
Hi Sandy!

It may happen because Google no longer supports the endpoint used in Bitrix. We have plans for this connection update, but I cannot advise when it will be released.ze for the inconvenience

We apologize for the inconvenience.

Best,

Yana.
Pages: 1
2,000,000+
organizations
are already using Bitrix24