Bitrix24 Community

Support » Forum » CRM » Bitrix adding spaces in message text
Pages: 1
RSS
Bitrix adding spaces in message text
Hi,

When I enter text in "Message Text" (CRM, business process, email message) Bitrix inserts spaces in the middle of words. This is completely reproducible. For example, if I enter the following text:
Code
<p>Our Networking Suite offers:
<ul>
<li>Your own Mortgage blog/website, upd ated daily with original content</li>
<li>Monthly e-newsletter ready to send to your contact list</li>
<li>Social Media set-up on the 3 major networking sites (all of which are upd ated daily)</li></ul></p>
Then "save", then edit the message, I will find in the first li, "upd ated" has become "upd ated" and in the third li, "se t-up" has become "se t-up".

There are other places where this happens consistently. For example, meta tags consistently become "met a". Which is an obvious problem.

Is this a known bug? Am I doing something wrong?

FYI, this is with Message Type se t to HTML, and Encoding se t to windows-1251.

Thanks!
Chris
Ha! Look at that. You must be using the same process for this forum! I did NOT have those spaces when I submitted this forum post. I wonder if it happens again if I just type \s\e\t\-\u\p: setup.
Weird. It didn't happen that time. Maybe "set-up" with quotation marks?
Hi Christopher,

I'm facing the same problem and I cannot find any solution online, did you managed to get it to work?

I hope you can post your solution,

All the best,
Jorg
Got an answer from the support team, sending emails in HTML through Business Processes DOES NOT WORK in cloud hosted versions:
Quote
This situation occurs because of module of proactive protection, it can separate tags by spaces.
Disable the module is only possible in a self-hosted version.
Hi,

It does not mean this option doesn't work, it means it involves proactive protection and empty space insert is done in purpose due to security reasons. We do understand this may not loke nice & we'll think about the updates for this in future (probabaly spring 2016 release may solve this issue).

Best,

Yana.
I agree that it is working, but it is not possible to send styled HTML emails for cloud-users via Business Proceses.

The main problem is that the proactive protection is splitting up the word "style", whether its in a <style> tag or an inline css style tag. This prevents the code to add any kind of styling to the email. I guess that if this word won't be splitted, the biggest part of the problem would already been solved.

Anyway, I'm looking forward to this future update. Meanwhile I feel forced to send out plain text emails.

Keep up the good work :)
Thank you!  :)

Best,

Yana.
Pages: 1
2,000,000+
organizations
are already using Bitrix24