Bitrix24 Community

Support » Forum » CRM » Authorization perpetually failing in REST API
Pages: 1
RSS
Authorization perpetually failing in REST API, Correct authorization details have been provide and are being passed to the API, but access denied
I'm trying to set up the form on our site to pass data directly to the API in order to automatically add leads into the system. I've used the example script provided on bitrix24.com/about/blogs/community-blog/lead-creation-from-external-services.php

However, even though the correct login details are being sent to the API, it returns a 403 error.

I've checked every step of the output and the values being processed are all correct. I've also double-checked by copy-pasting the login and password supplied in the code definitions into my regular login screen and they work perfectly. Yet, the API returns a 403 error.

The odd thing is that the output shows as if the operation was a success, but when I look in the CRM, it isn't.
You can view the form at: http :// tools.accuracast.com/marketing-review/test.php
And the output at: http :// tools.accuracast.com/marketing-review/rest.php with echo $result; so that you can see what's going on.

Could someone please help me figure out what's going wrong here?
Hi Farhad,

We do not observe the problem on our PCs, please submit a ticket to our Help Deskfor further technical assistance.

Thank you.

Yana.
Hi Yana,

I've submitted the ticket to the Help Desk last week but haven't had any response whatsoever. What is the normal turnaround time for such requests?
Hi Farhad,

Please check your inbox now, your ticket was replied. Thank you.

Regards,

Yana.
Pages: 1
2,000,000+
organizations
are already using Bitrix24