Bitrix24 Community

Support » Forum » Self-hosted version » Local Install Requirements for mbstring.func_overload
Pages: 1
RSS
Local Install Requirements for mbstring.func_overload, is there a workaround for requiring "mbstring.func_overload=2"
There is a server requirement related to the PHP parameter “mbstring.func_overload setting”. This needs to be set to the specific value of 2 for the system to operate. However, this is in direct conflict with our helpdesk which runs on the same server.

Can you check if there is a workaround to enable “mbstring.func_overload setting” parameter to operate with a value of “0” rather than “2” which is the current need.

Usually it would be possible to define this value in the htaccess file for each domain on the server, but PHP 5.2.8 onwards has a bug which will not allow that to happen for this specific parameter!
Hi, Brian!

If you are using UTF-8 encoding on your site, mbstring.func_overload should be set to the value of 2.
You can set different value to different sites on your server.
In this case, you should set the value in the files of virtual hosts settings (httpd.conf).

regards
Evgeniya
Pages: 1
2,000,000+
organizations
are already using Bitrix24